Skip to end of metadata
Go to start of metadata

Default Selenium Version

By default, Sauce Labs will use the following version of Selenium, depending on your selected combination of browser and operating system. While Selenium 3 is not yet fully implemented as a default version, it is supported for all Chrome and Firefox browsers on Mac and Windows platforms, for Safari 10+ on macOS 10.12 Sierra, and for Microsoft Edge and IE browsers version 10 and above. Currently Sauce Labs supports Selenium 3.4.0+ for Firefox and Safari and Selenium 3.5.0+ for Microsoft Edge and Chrome.

Browser NameDefault Selenium Version
Microsoft Edge2.52.0
Chrome

Latest Chromedriver

Firefox

Dev: 3.4.0

Beta: 3.4.0

53+: 3.4.0

39+: 2.53.1

Safari

11.0: 3.4.0

< 11.0: 2.48.0

Internet Explorer2.53.1

You can set the Selenium version for your tests by using the seleniumVersion desired capability:

'seleniumVersion' = '3.8.1'


  • No labels