Skip to end of metadata
Go to start of metadata

Return to the Product Announcements and Release Notes Blog

 

Dear Sauce user,

 

We are very excited to announce support for Firefox 58 on Sauce Desktop platforms. The new versions is available on all Mac and Windows Desktop platforms supported by Sauce.

Please set Firefox Desired Capability, "version" to "58.0" or "latest" to test on Firefox 58. Below is an example in Java to test on Firefox 58. 

 

DesiredCapabilities caps = DesiredCapabilities.firefox();
caps.setCapability("version", "58.0");

 

We verified that Selenium versions 3.4.0 through 3.8.1 are compatible with Firefox 58. However we noticed an issue with Implicit Wait commands in Selenium versions 3.5.0 and up. If your automated test scripts use Implicit Wait commands then we recommend using Selenium 3.4.4 or below.

 

Platform Configurator has been updated with an option for Firefox 58.

Best regards and happy testing,
The Sauce Labs Team